Orbiter-Forum  

Go Back   Orbiter-Forum > Projects > Site Support > Bug
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Notices

Uploading .zip file as post attachment fails Issue Tools
issueid=1422 06-24-2019 11:21 PM
Orbiter Founder
Uploading .zip file as post attachment fails

I just tried to upload a tileedit update in a zip file to this post: https://www.orbiter-forum.com/showth...40&postcount=1 and was told that "Upload of file failed."

Not sure if this is something to do with the forum code migration, or if it's a recurrence of this issue: https://www.orbiter-forum.com/project.php?issueid=1400
Issue Details
Project Site Support
Status Fixed
Priority 5 - Medium
Affected Version Unknown
Fixed Version (none)
Users able to reproduce bug 0
Users unable to reproduce bug 0
Assigned Users (none)
Tags (none)

06-25-2019 06:24 AM
Puts the Fun in Dysfunctional
 
File uploads are working in a general sense - I suspect this is a request size issue. How long is the file?
Reply
06-25-2019 09:54 AM
Orbiter Founder
 
Ah could be. I haven't got the file here right now - I'll check tonight. I think I remember that the zip files of the previous versions were in the 10-15MB region. Maybe the last one just went across whatever the limit is.
Reply
06-25-2019 06:46 PM
Orbiter Founder
 
Actually, the size of the zip file is a bit smaller than I thought: 4683KB, which should be within the quoted zip size limit of 5.77MB. Unfortunately I didn't keep the previous file that uploaded OK, so I can't say how big it was.

Is there some other per-user quota I might have reached, like total uploaded file size? I'm currently using 20.87MB for 87 attachments.
Reply
06-25-2019 08:51 PM
Puts the Fun in Dysfunctional
 
I suspect a misconfiguration, rather than an intentional low limit - but no, there's no per-user cap on uploads.

Have you been able to upload the file at all? I'm hunting for log files to trace the issue.
Reply
06-25-2019 09:58 PM
Orbinaut
 
Maybe some uploadfilter blocks .cfg files within the archive?
Reply
06-25-2019 11:02 PM
Orbiter Founder
 
Quote:
Originally Posted by Xyon
 Have you been able to upload the file at all? I'm hunting for log files to trace the issue.
I tried a couple of times yesterday and once today for good luck, but always with the same negative result. The zip file only contains a single exe file, nothing else.

Upload as 7z archive also fails, which would have been a bit smaller (4286MB)
Reply
06-26-2019 09:17 PM
Puts the Fun in Dysfunctional
 
PHP's filesize limit was too low; I've increased it, which restored my ability to upload a ~5MiB file.
Reply
06-26-2019 10:59 PM
Orbiter Founder
 
Excellent! Thanks for the fix. I tested the upload again and I can confirm that the problem is now resolved for me.

In the meantime I had circumnavigated the problem by dropping the file in question as a release directly on github and just linking to the release.
Reply
06-27-2019 07:54 AM
Puts the Fun in Dysfunctional
 
Quote:
Originally Posted by Marijn
 Maybe some uploadfilter blocks .cfg files within the archive?
Nice idea, but it's not advanced enough to look inside the zip files. OHM can, though.
Reply
Reply

Issue Tools
Subscribe to this issue

All times are GMT. The time now is 06:54 AM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.