Go Back   Orbiter-Forum > Projects > ORBITER: 2010-P1 and newer > Bug
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

pltex fails to merge surfaces greater than 2GB - causes display issues. Issue Tools
issueid=1068 10-11-2013 06:02 AM
pltex fails to merge surfaces greater than 2GB - causes display issues.
.tex file size approaches 32 bit signed size limit

When assembling one half of a Venus level 12 map, all 16 tiles more or less display properly, with a few missing level 9 patches per tile. The tiles are 16384x16384 across. All tiles are verified to be in their correct lat/lon regions before merging. Merged surfaces seem to be okay for columns E, F, G, and H, and regions EF and GH. A region is the size of a level 11 map, turned 90. The problem comes when I try to merge EF and GH together:

To iterate:
  1. Create tiles for each column. Create mipmaps = y
  2. Merge the tiles into positive and negative latitude areas. 0 to 90 and -90 to 0
  3. Merge the positive and negative latitude areas.
  4. Repeat for each column.
  5. Merge the columns E and F, then G and H.
  6. Merge EF and GH.

Expected result: Surface displays fine.
Observed result: The region from around -45 to 0 latitude uses only one patch.

EDIT: It seems there is a 2GB limit on planet surfaces, since when I tried to merge tile H1 to columns EFG, it worked fine, since the surface was 1.99 GB. However, when I then merged tile H2, the problem first appears. The file size of that surface is now 2 GB, and its bin 1,704 KB. Interesting, as I tried merging columns EF and GH all at once, but the file size for the .tex file was the same, but the bin was correctly written as 2 MB, so in effect, pointers in the 2 MB bin reference nonexistent tiles, thus creating the display issue. Also, when I tried to merge the surface [containing columns EFG with H1 and H2] with tile H3, this comes up:


Tile set 1 (VenusH12) contains 54512 tile descriptors
Tile set 2 (H3) contains 5550 tile descriptors

Merging         |==================================
pltex ERROR: Texture file parse error
Press a key to terminate.
Which furthers my suspicion that pltex doesn't like to handle big surfaces, even though it claims to support global level 14!

However, there was a resultant merge_tile.tex measuring 2.15 GB, but no accompanying tile.bin.

Please test this on both 32 bit and 64 bit versions of your OS to confirm.

This problem affects all builds of pltex past 100830, to the current trunk revision. All graphics clients are affected.

NEW pltex surface test - Merged surface EFG with tiles H1 through H4
Issue Details
Project ORBITER: 2010-P1 and newer
Status Not a Bug
Priority 1 - Highest
Affected Version 100830 (2010-P1)
Fixed Version (none)
Users able to reproduce bug 0
Users unable to reproduce bug 0
Assigned Users (none)
Tags (none)

09-17-2018 08:58 PM
Orbiter Founder
I am closing this, since pltex is a legacy tool that only operates on old-style (pre-2016) texture formats. All current celestial body projects should use the new texture format, which doesn't suffer from this problem.

(I marked it as "not a bug", but in fact it is something like "no longer applies.")

Issue Tools
Subscribe to this issue

All times are GMT. The time now is 04:06 PM.

Quick Links Need Help?

About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 2007 - 2017, Orbiter-Forum.com. All rights reserved.