Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Space Flight Simulator > General Questions & Help
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Notices

General Questions & Help General & Advanced Orbiter flight questions, Orbiter installation questions, to all other help topics here.

Reply
 
Thread Tools
Old 11-02-2010, 07:18 PM   #1
HAL9001
super-ninja-orbinaut
 
HAL9001's Avatar
Default how to add spacecraft3-vessels to scenario?

How can I add spacecraft-3-vessels to the scenario?
I can't add them with the scenario-editor.

greets, hal9001
HAL9001 is offline   Reply With Quote
Old 11-02-2010, 07:39 PM   #2
Izack
Non sequitur
 
Izack's Avatar

Default

You need to add a cfg file to the Vessels folder.

You would create a file called <your vessel name without spaces>.cfg, which would look like this:
Code:
ClassName = <same as filename>
Module = Spacecraft3
When you spawn it with the scenario editor, the vessel name you enter MUST be the same as the file/class name (what you see in the vessel list.)

So for the James Cook, it would be JamesCook.cfg, reading:
Code:
ClassName = JamesCook
Module = Spacecraft3
and you would name the vessel JamesCook.

You can choose other names/add more of the same vessel to a scenario by creating other CFG files and INI files in the Config\Spacecraft folder with the same contents, only with different file and class names.

So you could copy JamesCook.ini, paste it in the same directory, rename it BotanyBay.ini, then create a new config file under Config\Vessels called BotanyBay.cfg, with ClassName = BotanyBay, add both with the scenario editor and voila! you have two of the same ship.
Izack is offline   Reply With Quote
Old 03-15-2017, 11:30 AM   #3
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

So I am trying to get this to work. So in the config/vessel folder I have a cfg named:
BARM1.cfg

and in it is:
Code:
; === Configuration file for spacecraft3 ===
ClassName = BArm1
Module = Spacecraft3
BArm1 is the name of .ini in the spacecraft folder.

When I load it in SCN editor no mesh shows up?
gattispilot is offline   Reply With Quote
Old 03-15-2017, 12:46 PM   #4
Trekkie
Starfleet Captain
 
Trekkie's Avatar
Default

Quote:
Originally Posted by gattispilot View Post
 So I am trying to get this to work. So in the config/vessel folder I have a cfg named:
BARM1.cfg

and in it is:
Code:
; === Configuration file for spacecraft3 ===
ClassName = BArm1
Module = Spacecraft3
BArm1 is the name of .ini in the spacecraft folder.

When I load it in SCN editor no mesh shows up?
Check if the mesh file is the Same as in the ini file and try to keep the ini and the vessel named the same
Trekkie is offline   Reply With Quote
Old 03-15-2017, 01:17 PM   #5
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Thanks. So when you add the vessel the name must be the same as the cfg.
Code:
BArm1:BArm1
  STATUS Orbiting Earth
  RPOS 6995440.87 0.00 421220.53
  RVEL -453.291 -0.000 7528.050
  AROT 0.00 0.00 0.00
  AFCMODE 7
  NAVFREQ 0 0
  RCS 1
  CTRL_SURFACE 1
  CONFIGURATION 1
  CURRENT_PAYLOAD 0
  SEQ 0 -2 0.000000
  SEQ 1 -2 0.500000
  SEQ 2 -2 0.500000
  SEQ 3 -2 0.500000
  SEQ 4 -2 0.500000
  SEQ 5 -2 0.500000
  SEQ 6 -2 0.500000
  SEQ 7 -2 0.500000
  SEQ 8 -2 0.125000
END
gattispilot is offline   Reply With Quote
Old 03-15-2017, 01:19 PM   #6
DaveS
Addon Developer
 
DaveS's Avatar


Default

Quote:
Originally Posted by gattispilot View Post
 Thanks. So when you add the vessel the name must be the same as the cfg.
Code:
BArm1:BArm1
  STATUS Orbiting Earth
  RPOS 6995440.87 0.00 421220.53
  RVEL -453.291 -0.000 7528.050
  AROT 0.00 0.00 0.00
  AFCMODE 7
  NAVFREQ 0 0
  RCS 1
  CTRL_SURFACE 1
  CONFIGURATION 1
  CURRENT_PAYLOAD 0
  SEQ 0 -2 0.000000
  SEQ 1 -2 0.500000
  SEQ 2 -2 0.500000
  SEQ 3 -2 0.500000
  SEQ 4 -2 0.500000
  SEQ 5 -2 0.500000
  SEQ 6 -2 0.500000
  SEQ 7 -2 0.500000
  SEQ 8 -2 0.125000
END
Not the cfg file but the INI file. The vessel name tells SC3 which INI file to load. So a vessel with the name of "801bc" tells SC3 to load the INI file named "801bc.INI" in the Config\Spacecraft folder.
DaveS is online now   Reply With Quote
Thanked by:
Old 03-15-2017, 01:33 PM   #7
gattispilot
Addon Developer
 
gattispilot's Avatar
Default

Ok So make sure .ini and .cfg are the same names. It looks like the Vessel names needs to be the same also.
gattispilot is offline   Reply With Quote
Old 03-15-2017, 06:59 PM   #8
Trekkie
Starfleet Captain
 
Trekkie's Avatar
Default

Quote:
Originally Posted by gattispilot View Post
 Ok So make sure .ini and .cfg are the same names. It looks like the Vessel names needs to be the same also.
Correct, so if you would have for instance an ini file named Enterprise then the vessel in game has to have the Same name in order for it to load( i also always have the ini and .cfg the Same names just to be sure)
Trekkie is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Space Flight Simulator > General Questions & Help


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 07:28 AM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2007 - 2012, Orbiter-Forum.com. All rights reserved.