Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Addons > Addon Development
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Notices

Addon Development Developers post news, updates, & discussions here about your projects in development.

Reply
 
Thread Tools
Old 04-22-2017, 10:49 AM   #751
1987VCRProductions
Orbinaut
 
1987VCRProductions's Avatar
Default

I've been working on my own Multistage2015 Saturn launchers and I plan on releasing it next month. I've noticed that with the most recent version of Multistage2015 for Orbiter 2010 P1 that my launchers are overshooting their programmed orbital inclination by 0.07 degrees. Instead of an orbit of 51.6 I get and orbit of 51.67 and etc. for every other inclination.

---------- Post added at 10:49 AM ---------- Previous post was at 10:46 AM ----------

In previous versions of Multistage2015 my planned orbital inclinations were spot on.
1987VCRProductions is offline   Reply With Quote
Old 04-22-2017, 11:26 AM   #752
boogabooga
Bug Crusher
 
boogabooga's Avatar
Default

Have you turned on or off non-spherical gravity sources?
boogabooga is offline   Reply With Quote
Old 04-22-2017, 12:01 PM   #753
1987VCRProductions
Orbinaut
 
1987VCRProductions's Avatar
Default

Quote:
Originally Posted by boogabooga View Post
 Have you turned on or off non-spherical gravity sources?
It's off. I don't turn those settings on.
1987VCRProductions is offline   Reply With Quote
Old 04-22-2017, 01:52 PM   #754
boogabooga
Bug Crusher
 
boogabooga's Avatar
Default

It's working just fine for me.
boogabooga is offline   Reply With Quote
Old 04-22-2017, 02:33 PM   #755
1987VCRProductions
Orbinaut
 
1987VCRProductions's Avatar
Default

I'm using Orbiter 2010 P1 so I can't vouch for Orbiter 2016. I'll run some more tests later.
1987VCRProductions is offline   Reply With Quote
Old 04-22-2017, 02:40 PM   #756
boogabooga
Bug Crusher
 
boogabooga's Avatar
Default

I'm using Orbiter 2010 P1 as well.
boogabooga is offline   Reply With Quote
Old 04-24-2017, 12:48 AM   #757
1987VCRProductions
Orbinaut
 
1987VCRProductions's Avatar
Default

Ah, a mystery. Could be any number of things. I'll try it with a clean Orbiter install just to verify that the problem is solely on my end and then work from there.

---------- Post added 04-24-17 at 12:48 AM ---------- Previous post was 04-23-17 at 06:45 PM ----------

Yet a deeper mystery. Launches from KSC at lower inclinations (i.e. 28.62 or 32.5 at headings of 90 or 72) give me an accurate spot on inclination at cutoff. Launches to higher inclinations of 50 or 51.6 give odd inclination overshoots at cutoff (overshooting by 0.07).

It could be my install of Multistage 2015. I've gone back and forth between different builds of MS2015 so a file or two might have gotten messed up. I'll methodically remove all files pertaining to the working of MS2015 and reinstall it to see if that fixes it. I don't want to go through the trouble of setting up a clean install of Orbiter just yet.
1987VCRProductions is offline   Reply With Quote
Old 04-24-2017, 12:56 AM   #758
fred18
Addon Developer

Default

That's very curious!!!
I'll investigate that to see if i can reproduce the bug
fred18 is offline   Reply With Quote
Old 04-24-2017, 02:05 AM   #759
1987VCRProductions
Orbinaut
 
1987VCRProductions's Avatar
Default

Quote:
Originally Posted by fred18 View Post
 That's very curious!!!
I'll investigate that to see if i can reproduce the bug
I just tested your SLS launcher and it overshot the inclination listed in the Guidance file by 0.02. Some of my Saturns have given me that exact overshoot too. I'll bite the bullet and set up a clean install of Orbiter and try again.

---------- Post added at 01:21 AM ---------- Previous post was at 01:17 AM ----------

I might add that I tested the Energia-Buran from Baikonur (I'd updated it to use Multistage 2015) and it got an accurate inclination of 51.6 at cutoff (launch heading of around 62).

---------- Post added at 01:43 AM ---------- Previous post was at 01:21 AM ----------

I tested the SLS with a clean install and was still getting an inclination overshoot. I noticed that the stages were disappearing and I noticed that stage.cfg was included in the latest update (I thought I was already using the latest update) so I'll redownload it and try that on the clean install.

---------- Post added at 02:05 AM ---------- Previous post was at 01:43 AM ----------

Still getting an overshoot and the stages keep disappearing, I guess I was using the latest version for 2010 P1 after all.
1987VCRProductions is offline   Reply With Quote
Old 04-24-2017, 04:56 AM   #760
fred18
Addon Developer

Default

Stages disappear because also stage.dll is missing, my fault, will fix it with sound support asap. Copy paste it from old installation of orbiter.

What's your average fps and what do you have as mfd refresh rate? Do you use vertical sync?

---------- Post added at 05:56 ---------- Previous post was at 05:24 ----------

Ok,

Good news:
I was somehow capable of reproducing the bug. Don't know how I did it, but I made it. Second good news is that the bug is not present in 2016 version so I can double check again. Don't get crazy, I'll work on this! Thanks for pointing that out.
fred18 is offline   Reply With Quote
Old 04-24-2017, 06:30 AM   #761
1987VCRProductions
Orbinaut
 
1987VCRProductions's Avatar
Default

Thanks! I really appreciate all the work you do. I'm glad I stumbled upon that glitch so that it could be fixed.

My frame rate is typically very good. I'll check real fast what frame rates I typically run at and then I'll get back to you on what my vertical sync setting is (I can't remember off the top of my head). I believe my MFD refresh rate is set to 0.10 seconds.

---------- Post added at 06:30 AM ---------- Previous post was at 06:10 AM ----------

I had vertical sync disabled but I also disabled hardware pageflip which greys out the option to disable vertical sync. My MFD refresh rate is 0.10 seconds. The lowest framerates I pull with my Saturn rockets are somewhere in the low to mid 30s on the launchpad external view and mid to high 20s internal view. I'm fairly satisfied with the fps I get compared to what I used to get when I did everything on my old laptop. When my laptop was still alive I would get framerates in the single digits with my Saturn V launchers in the external view.
1987VCRProductions is offline   Reply With Quote
Thanked by:
Old 04-24-2017, 08:23 AM   #762
fred18
Addon Developer

Default

Could you please check if this works fine?
Attached Files
File Type: zip Modules.zip (423.7 KB, 0 views)
fred18 is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Addons > Addon Development


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 09:31 AM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2007 - 2012, Orbiter-Forum.com. All rights reserved.