Orbiter-Forum  

Go Back   Orbiter-Forum > Projects > ORBITER: 2010-P1 > Bug
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

oapiGetPlanetTheta() returns nonzero value for Earth Issue Tools
issueid=930 03-13-2012 08:24 AM
Orbinaut
oapiGetPlanetTheta() returns nonzero value for Earth
The API Reference states that it must be 0.

Code:
  OBJHANDLE earth = oapiGetObjectByName("Earth");  double theta = oapiGetPlanetTheta(earth) ; // theta = -0.002487...
But the API reference says:
Quote:
For Earth, this function will return 0. (The ascending node of Earth’s equatorial plane is the definition of the vernal equinox).
Other Orbiter versions may be affected as well.
Issue Details
Project ORBITER: 2010-P1
Status Not a Bug
Priority 10 - Lowest
Affected Version 100830 (2010-P1)
Fixed Version (none)
Users able to reproduce bug 0
Users unable to reproduce bug 0
Assigned Users (none)
Tags (none)

03-13-2012 05:36 PM
Beta Tester
 
Not a Bug. That was the case before the planet precession code was implemented. It should return zero for the Earth 1.1.2000 12:00
Reply
03-15-2012 07:37 AM
Orbinaut
 
Ok, understood. The SDK documentation still says that the rotation axis is fixed. I hereby withdraw my bug report. Thanks a lot!
Reply
Reply

Issue Tools
Subscribe to this issue

All times are GMT. The time now is 07:13 AM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©2007 - 2012, Orbiter-Forum.com. All rights reserved.